Main      Site Guide    
Message Forum
dragon in cave in game of ages
Posted By: Senvy, on host
Date: Thursday, October 18, 2001, at 10:55:38

I killed the wraith and went off down one of the tunnels, and now a dragon has me trapped. I tried rushing by it, but the south corridor is blocked, and now I'm stuck in an endless cycle of attacking, dodging, parrying, and running back and forth, but I can't get back to where I killed the wraith. I'm trapped! Every time I try to get back to the portal, I trip or ram into a wall or something else happens, and I have to start fighting all over again.
Should I just start the game over? Does the dragon die ( very ) eventually, or is there a specific attack sequence that I haven't tried yet?

I have the guard's sword, and the only options avaiable to me are:
*Attack the dragon with your sword.
*Parry the attack with your sword.
*Dodge the attack.
*Examine the dragon.

And, eventually,

*Run away to the south. (dead end, have to run back, start all over again), and,
*Rush around the dragon to the west. (trip, fall down, dragon blocks me, etc.)

What do I do????

Replies To This Message

Post a Reply

Note: If you are posting a hint request for Adventure Games Live, be sure to specify which game you are talking about and list your inventory so other players know where you are in the game.

RinkChat Username:
Email: (optional)
Link URL: (optional)
Link Title: (optional)

Make sure you read our message forum policy before posting.